Import Parts

You can import different file formats to CypCut. The import functions launched from the pulldown-menu File>Import import parts into the drawing window.

Import Parts into Drawing Window

On the other hand, the import functions launched from the menu Nest>Part import parts directly into the part library, refer to Part Library for more information.

Import Parts into Library

Here is a list of the supported file formats:

  • LXD (CypCut)
  • DXF (AutoCAD)
  • PLT
  • AI (Adobe Illustrator)
  • Gerber
  • G Code

Import into the Drawing Window

Let’s go through the steps for importing a DXF file into the drawing window. Importing other files works just like this one.

Select the command Import from the pulldown-menu File, then Import DXF File. Search for the DXF file in the Windows dialog box and click on Open.

Search for the DXF File

The placement of the drawing will be shown as a placeholder which sticks to the mouse cursor, set it to where you want in the drawing window.

Place the Parts

Now the software executes various activities, which you have to define or check first. Open User Settings from the pulldown-menu File>User Setting.

Settings for Importing

These settings will be executed on the file when importing, i.e. removing tiny elements, deleting duplicated elements, etc.

And then the optimized drawing of the DXF file is displayed in the drawing window. Apart from the contours you might also see construction and dimensioning lines plus drawing information which you do not want to import.

Drawing

Select and remove those unwanted elements to "isolate" the contours.

Contour

Finally, check the parts for open contours and correct any mistakes if necessary.

Drawing Optimizations

Sometimes, there are still open contours (shown in red if the view function Show unclosed curve as red is active) and other kinds of issues left in the parts after the default optimizations executed when importing.

Open Contour

That is due to the drawing issues exceed the range of the corrections that the default optimizations can make, e.g. the gaps in the open contours are too big to close.

Open Contour Details

In these cases, we need to correct the issues manually by ourselves. Here is a list of the drawing optimization functions in CypCut:

Icon Label Function
Smooth Smooth To reduce jagged edges in polylines.
Split Split To split curves or polylines into segments, for further treatment.
Remove Duplication To remove duplicated drawing elements which are overlapping on or too close to each other.
Remove trivial To remove drawing elements which are too small.
Combine near To close opening contours.
Chop Chop To split scraps into smaller pieces, help them fit through the strip cutting bed, avoiding interference with the laser head.
Plate Separate

Let’s go through the steps for closing opening contours. The other optimization functions work just like this one.

Select the opening contours which are going to be closed. Then select the command Combine near in the menu Home>Optimize or in the menu Draw.

Close Open Contours

Set a value there bigger than the dimension of the gap and click on OK, then the opening contours will be closed.

You can select the command Measure in the menu Home to measure the gap if you have no idea about the dimension. Just follow the prompts in the Draw command window to complete the command.

Measure the Gap

Import into the Part Library

The software will also execute the default optimizations when importing parts directly into the part library. Unlike importing into the drawing window, this function will not display anything in the drawing window and will split drawing elements which are apart from each other into separate parts automatically.

For example, the drawing below will be imported as the two parts on the right side.

Import Behavior Explaining
Import Behavior Explaining

Here we will focus on discussing the possible issues you may encountered.

Let’s try to import the handle (being used as an example in Import into the Drawing Window).

Unfortunately, you will get two unexpected parts in the library.

Issue on Importing Parts

The first part is the annotate in the DXF file.

Part 1

The second part includes the construction lines.

Part 2

In this case, there are elements which you do not want to import. You should follow the steps in Import into the Drawing Window to complete the importing, select the contours you want to put in the library, and right-click to bring up the context menu, then select the command Add to Part Lib.

Add to the Part Library

Let’s have another try on importing the part (being used as an example in Drawing Optimizations).

Once again, you will not get the expected part in the library.

Issue on Importing Parts

The first part is the lower half of the whole part.

Part 1

The second part is the upper half of the whole part.

Part 2

In this case, the default optimizations do not close the opening contour successfully, and the software split it into two separate parts. In the same way, you should follow the steps in Import into the Drawing Window to complete the importing, close the contour manually (refer to Drawing Optimizations for more information), and then add it to the part library just as before.

Similarly, if the default optimizations do not remove duplicated or tiny drawing elements successfully, the software will import them as separate parts as well. Then you should follow the same process to solve the issues.

Leave a Reply

Your email address will not be published. Required fields are marked *